Memsource Editor

Important

As of January 2021, all outdated OS support ends and their corresponding Memsource Editor for Desktop versions will no longer function. This is due to the deprecation of Legacy APIs. An updated OS and editor version will be required. Editor versions 20.16.x and below will no longer work.

Download the latest version to use with an updated OS.