Memsource Editor for Desktop

Desktop Editor Commands

Editor commands can be launched either from the menu, quick access buttons at the top of the application or through keyboard shortcuts. Here, you'll find a list of the keyboard shortcuts that you can use in the Memsource Editor for your desktop.

Edit Menu

Confirm (Ctrl+Enter)

  • Confirms segment as translated and saves it into TM

 

Unconfirm (Ctrl+Shift+Enter)

  • Unconfirms a segment

 

Copy Source to Target (Ctrl+Insert or Cmd+Shift+I on Mac)

  • Copies text in the source segment to the target segment and also works for any selection of the source text

 

Delete Target (Ctrl+D)

  • Deletes text in the target segment based on the following:
    • If the segment is selected (by clicking on the segment number), the entire content of the segment will be deleted
    • If the cursor is placed at the beginning or end of a segment, the entire content of the segment will be deleted
    • If the cursor is placed anywhere else in the segment, this command will delete everything after the cursor

 

Tags
Insert Tag (F8)
  • Inserts tags; when inserting {1>paired tags<1}, first select the text you want to enclose in tags and only then hit the Insert Tag command. This way, both tags will be inserted at once around the selected text.
Insert All Tags (Ctrl+Shift+F8)
  • Inserts all tags from the source segment at the cursor position in the target segment.
 Insert Tag Number (Ctrl+Alt+Tag Number or Cmd+Option+Tag Number on Mac)
  • Inserts a specific tag from the source segment where the cursor is positioned in the target segment.
 Insert Tag by Selection (Ctrl+, or Cmd+, on Mac)
  • Selects a specific tag from a drop-down list.

       Create Custom Tag (Alt+F8)

  • Creates an arbitrary, unpaired tag in the target (supported for XLIFF, HTML, and XML source files).
Create Custom Paired Tag (Alt+Shift+F8)
  • Creates an arbitrary paired tag in the target (supported for XLIFF, HTML, and XML source files).
Expand Tags (Ctrl+Shift+E)
  • Expands tags and displays the tag content (supported for XLIFF, HTML, and XML source files).
Remove All Tags (Ctrl+F8)
  • Remove all tags from the target.

 

Toggle Case (Shift+F3)

  • Toggles upper case to lower case and vice versa

 

Insert symbol
 
Insert Non-breaking Space (Ctrl+Shift+Space)
  • Inserts a non-breaking space.
Insert Non-breaking Hyphen
  • Inserts a non-breaking hyphen.
Insert Left-to-Right Mark (Ctrl+Alt+Shift+L or Cmd+Alt+Shift+L on Mac)
  • Inserts a left-to-right mark in the target segment.
Insert Right-to-Left Mark (Ctrl+Alt+Shift+R or Cmd+Alt+Shift+R on Mac)
  • Inserts a right-to-left mark in the target segment.
Insert New Line (Shift+Enter)
  • Inserts a line break.
More Symbols... (Ctrl+Shift+L)
  • Opens a window for adding various symbols.

 

Undo (Ctrl+Z)

  • Undo the last action.

 

Redo (Ctrl+Y)

  • Redo the last action.

 

Split Segment (Ctrl+E)

  • Splits a segment in two. The cursor has to be in the source segment in order to split.

 

Join Segment (Ctrl+J)

  • Joins the selected segment with the segment below.

 

Lock/Unlock Segment (Ctrl+L)

  • Locks or unlocks the selected segment (this option is not available for Linguists).

 

Repetition Exception

 

Select All Segments (Ctrl+Shift+A)

  • Selects all segments.

 

CAT Results
 
CAT Results Move Up (Ctrl+ArrowUp or Cmd+Up on Mac)
  • Moves the cursor up to the next result in the CAT pane.
CAT Results Move Down (Ctrl+ArrowDown or Cmd+Down on Mac)
  • Moves the cursor down to the next result in the CAT pane.
CAT Results Insert (Ctrl+Space or Cmd+Ctrl+Space on Mac)
  • Inserts the selected TM or TB match into the appropriate segment.
CAT Results Insert from
  • E.g. Ctrl+1 inserts match no. 1 in the appropriate segment.

 

Move to First Segment (Ctrl+Home)

  • Moves the cursor to the first segment.

 

Move to Last Segment (Ctrl+End)

  • Moves the cursor to the last segment.

 

Toggle Cursor Source/Target (Ctrl+Tab)

  • Moves the cursor between the source and target.

 

Edit Source (F2)

  • Edits the source text (e.g. where a typing error needs to be corrected).
  • Edits the locked segment (available only if it's allowed in the Project Settings).

 

Open Conversations (Ctrl+M)

  • Opens the Comments window.

 

Add New Comment (Ctrl+Shift+M)

  • Adds a new comment to a new or existing conversation.

 

Overwrite Mode (Ins or CTRL+CMD+I on Mac)

  • Enables the Overwrite mode (not currently supported for Chinese, Japanese and Korean).

 

Tools Menu

Find (Ctrl+F)

  • Opens the Find window.

 

Find/Replace (Ctrl+H)

 

Find Next (F3)

  • Finds next

 

Find Previous (Alt+F3)

  • Finds previous

 

Filter (Ctrl+Shift+F)

  • Filters segments with the selected text

 

Add Term (CTRL+T or ALT+T)

  • Adds the selected text to a term base (hit Enter to save the new terms, hit Esc to close the new term window)

 

Search* TM/TB (CTRL+K)

  • Searches the project translation memories and term bases for the selected word or phrase using a wildcard search.

 

Search TM/TB (CTRL+SHIFT+K)

  • Searches the project translation memories and term bases for the selected word or phrase using an exact search (in quotes).

 

Spellcheck (F7)

  • Launches the spellchecker

 

Run QA (F9)

  • Launches Quality Assurance Check

 

Context Note (Alt+N)

  • Show/hide the Context Note window at the bottom of the Editor.
  • This option is disabled for jobs with Plural forms and the Context Note is always open.

 

Preview

  • Offers real-time preview of the translated segment. Available only for specific file formats: Microsoft Word, HTML, XML with XSL template and DITA.
    • Disable
    • Source
    • Target

 

Go to Segment (CTRL+G)

  • Jumps to the segment with a specified number

 

Customize Shortcuts

  • Customize the keyboard shortcuts

 

Restore Default Layout

  • Restores the default layout of the windows and tabs

 

Preferences

Format Menu

Bold (Ctrl+B)

Italic (Ctrl+I)

Underline (Ctrl+U)

Subscript (Ctrl+-)

Superscript (Ctrl+Shift+-)

Quotation

  • Select the settings for how quotations are displayed in the Desktop Editor for both the source and target languages. For example, you can set up Memsource to produce straight quotation marks instead of curly ones.

Show spaces

  • Toggle this to display hidden characters (such as spaces, non-break spaces, or new lines).

Document Menu

View Original

  • Opens the original (source) file.

 

Preview Translation

  • Opens the translated (target) file.

 

Upload to Server

  • Uploads all translated (confirmed and unconfirmed) segments to the server. However, only confirmed segments are saved to the translation memory.

 

Export to Bilingual DOCX

  • Converts an MXLIFF file to a bilingual DOCX file.

 

Import from Bilingual DOCX

  • Converts a DOCX file to a bilingual MXLIFF file.