Memsource Editor for Web

Editor for Web Commands

Commands can be launched from the menu, quick access buttons at the top of the application, or through keyboard shortcuts. Here, you'll find a list of the keyboard shortcuts that you can use in Memsource.

Edit Menu

The following is a list of the commands that are found under the Edit menu in the Memsource Editor.


Edit menu

 

Confirm (Ctrl+Enter)

  • Confirms a segment as translated and saves it into the TM. It is recommended that you confirm every segment right after translating it; confirming all segments in a batch can cause problems in larger jobs.

 

Unconfirm (Ctrl+Shift+Enter)

  • Unconfirms a segment

 

Copy Source to Target (Ctrl+Insert or Cmd+Shift+I on Mac)

  • Copies the source segment to the target segment. This also works for any selection of the source text.

 

Delete Target Text (Ctrl+D)

  • Deletes text in the target segment based on the following:
    • If the segment is selected (by clicking on the segment number), the entire content of the segment will be deleted
    • If the cursor is placed at the beginning or end of a segment, the entire content of the segment will be deleted
    • If the cursor is placed anywhere else in the segment, this command will delete everything after the cursor
Tags
Insert Tag (F8)
  • Inserts tags; when inserting {1>paired tags<1}, first select the text you want to enclose in tags and only then hit the Insert Tag command. This way, both tags will be inserted at once around the selected text.
Insert All Tags (Ctrl+Shift+F8)
  • Inserts all tags from the source segment at the cursor position in the target segment.
 Insert Tag Number (Ctrl+Alt+Tag Number or Cmd+Option+Tag Number on Mac)
  • Inserts a specific tag from the source segment where the cursor is positioned in the target segment.
 Insert Tag by Selection (Ctrl+, or Cmd+, on Mac) 
  • Selects a specific tag from a drop-down list.

       Create Custom Tag (Alt+F8)

  • Creates an arbitrary, unpaired tag in the target (supported for XLIFF, HTML, and XML source files).
Create Custom Paired Tag (Alt+Shift+F8)
  • Creates an arbitrary paired tag in the target (supported for XLIFF, HTML, and XML source files).
Expand Tags (Ctrl+Shift+E)
  • Expands tags and displays the tag content (supported for XLIFF, HTML, and XML source files).
Remove All Tags (Ctrl+F8)
  • Remove all tags from the target.

 

Toggle Case (Shift+F3)

  • Toggles upper case to lower case and vice versa.
 
Insert symbol
 
Insert Non-breaking Space (Ctrl+Shift+Space)
  • Inserts a non-breaking space.
Insert Non-breaking Hyphen
  • Inserts a non-breaking hyphen.
Insert Left-to-Right Mark (Ctrl+Alt+Shift+L or Cmd+Alt+Shift+L on Mac)
  • Inserts a left-to-right mark in the target segment.
Insert Right-to-Left Mark (Ctrl+Alt+Shift+R or Cmd+Alt+Shift+R on Mac)
  • Inserts a right-to-left mark in the target segment.
Insert New Line (Shift+Enter)
  • Inserts a line break.
More Symbols... (Ctrl+Shift+L)
  • Opens a window for adding various symbols.

 

Undo (Ctrl+Z)

  • Undo the last action.

 

Redo (Ctrl+Y)

  • Redo the last action.

 

Split Segment (Ctrl+E)

  • Splits a segment in two. The cursor has to be in the source segment in order to split.

 

Join Segment (Ctrl+J)

  • Joins the selected segment with the segment below.

 

Lock/Unlock Segment (Ctrl+L)

  • Locks or unlocks the selected segment (this option is not available for Linguists).

 

Repetition Exception

 

Select All Segments (Ctrl+Shift+A)

  • Selects all segments.

 

CAT Results
CAT Results Move Up (Ctrl+ArrowUp or Cmd+Up on Mac)
  • Moves the cursor up to the next result in the CAT pane.
CAT Results Move Down (Ctrl+ArrowDown or Cmd+Down on Mac)
  • Moves the cursor down to the next result in the CAT pane.
CAT Results Insert (Ctrl+Space or Cmd+Ctrl+Space on Mac)
  • Inserts the selected TM or TB match into the appropriate segment.
CAT Results Insert from
  • E.g. Ctrl+1 inserts match no. 1 in the appropriate segment.

 

Move to First Segment (Ctrl+Home)

  • Moves the cursor to the first segment.

 

Move to Last Segment (Ctrl+End)

  • Moves the cursor to the last segment.

 

Toggle Cursor Source/Target (Ctrl+Tab)

  • Moves the cursor between the source and target.

 

Edit Source (F2)

  • Edits the source text (e.g. where a typing error needs to be corrected).
  • Edits the locked segment (available only if it's allowed in the Project Settings).

 

Open Conversations (Ctrl+M)

  • Opens the Comments window.

 

Add New Comment (Ctrl+Shift+M)

  • Adds a new comment to a new or existing conversation.

 

Overwrite Mode (Ins or CTRL+CMD+I on Mac)

  • Enables the Overwrite mode (not currently supported for Chinese, Japanese and Korean).

Tools Menu

The following are the commands found in the Tools menu.

Twe-tools-menu.png
Tools menu

 

Filter (Ctrl+Shift+F)

  • Filters segments with the selected text.

 

Add Term (Alt+T)

  • Adds a new term to the term base in Write mode (hit Enter to add the term, and hit Esc to close the New Term window).

 

Search* TM/TB (Ctrl+K)

  • Searches the project's translation memories and term bases for the selected word or phrase using a wildcard search.

 

Search TM/TB (Ctrl+Shift+K)

  • Searches the project's translation memories and term bases for the selected word or phrase using an exact search (in quotes).

 

Spellcheck (F7)

  • Launches the spellchecker.

 

Context Note (Alt+N)

  • Shows/hides the Context window at the bottom of the Editor.
  • This option is disabled for jobs with Plural forms and the Context Note is always open.

 

Preview

  • Offers a real-time preview of the translated segment. This is available only for specific file formats: Microsoft Word, HTML, XML with XSL template, and DITA.
    • Disable
    • Source
    • Target

 

Go to Segment (CTRL+G)

  • Jumps to the segment with the specified number.

 

Preference

Opens the Preferences window, which has three tabs.
  • The CAT tab:
    • Set the Minimum match rate for translation memory matches to get displayed and used for pre-translation.
    • Select the desired behavior after confirming a segment (e.g. if Next unconfirmed segment is selected, the cursor will automatically jump to the next unconfirmed segment after confirming a segment).
    • Set the Pre-translate options, which control whether or not the next segment is pre-translated after a segment is confirmed. The CAT tab also includes the option to enable/disable the auto-propagation of repetitions. Admins and Project Managers can decide if translations of repeated source text segments are automatically input into the corresponding target text segments or not. They can also choose whether Linguist users can control this setting. See the article on access and security settings.
    • Select Insert machine translation to have segments pre-translated with machine translation when a TM match above the minimum specified threshold is not available. Please note that this option will only work if machine translation has been activated for the project by the Project Manager.
  • Appearance tab:
    • Select the font size of the translation table and panes.
  • The Misc tab:
    • Enable Auto-complete.

Format Menu

Here you will find a list of the options available under the Format menu.

Twe-format-menu.png
Format menu

 

Bold (Ctrl+B)

Italic (Ctrl+I)

Underline (Ctrl+U)

Subscript (Ctrl+-)

Superscript (Shift+Ctrl+_)

Quotation

  • Select the settings for how quotations are displayed in the Editor for Web for both the source and target languages. For example, you can set up Memsource to produce straight quotation marks instead of curly ones.

 

Display Hidden Characters

  • Toggle this to display hidden characters (such as spaces, non-break spaces, or new lines).

Document Menu

Here is a list of the options available in the Document menu.

TWE_menu_Document.png
Document menu

 

View Original

  • Opens the original (source) file.

 

Preview Translation

  • Opens the translated (target) file.
  • For IDML files opens the translated (target) file as a PDF. This is available only with Frontlab Integration.

 

Export to Bilingual MXLIFF

  • MXLIFF files can be opened in the Memsource Editor for Desktop.

 

Export to Bilingual DOCX

  • Bilingual DOCX files can be opened and edited in MS Word.

 

Import from Bilingual DOCX

  • Imports data from a Memsource Bilingual DOCX back to the Memsource server.

 

View Project

  • Opens the project.